Windows 7

Ostatnio postanowiłem wypróbować nowe dziecko Microsoftu. Poprzez uczelnię mam dostęp do wydania Windows 7 Professional, dlatego chciałem dać mu szansę do zaprezentowania się i może nawet zastąpienia Linuxa (sic!) na moim dysku na stałe.

Mój zapał dotyczący nowego systemu trwał kilka godzin. Były to godziny poświęcone na ściągnięcie i nagranie na płytę odpowiedniego obrazu…

Po zbootowaniu z płyty ujrzałem piękne okienko ze sporym przyciskiem na środku „Install now…”. Pomyślałem, że to dobry punkt wyjścia więc klikąłem ów przycisk. Pojawił się wówczas napis „Setup is starting…”. To by się nawet zgadzało z intuicją. Niestety później było już tylko gorzej.

Po ostatniej informacji o startowaniu instalatora pojawiło się nowe okienko wraz z informacją, że nie mam sterownika CD/DVD i jeśli mam płytę/pendrive/cokolwiek ze sterownikami to mam to wykorzystać i załadować go.

Zadanie to nie wydaje się przesadnie trudne jeśli się nad nim głębiej nie zastanowić. Hej, czy ja nie bootowałem systemu z płyty? To teraz nagle odkrył, że nie może z niej czytać? Jeśli dodać do tego fakt, że przy poszukiwaniach sterownika mogę przeglądać sobie płyty, pendrive’y i zawartość dysku twardego to ktoś tu zmyśla.

Zacząłem poszukiwania internetowe dotyczące feralnego komunikatu. Jak się okazało nie byłem odosobnionym przypadkiem. Niektórzy sobie z tym poradzili i znalazłem kilka zaleceń how-to. Jedno z nich dotyczyło pogmerania przy ustawieniach RAID dla SATA w BIOSie. Niestety BIOS w moim laptopie (Acer Aspire 5610Z) pozwala jedynie zmienić kolejność bootowania…

Później ktoś poradził, aby zainstalować system z pendrive’a. Nagrałem więc obraz Win7 na 4GB patyk i zbootwałem z niego system. Podbudowała mnie szybkość bootowania ale dzięki niej o wiele prędzej dowiedziałem się, że nic to nie dało.

Kolejną poradą było załadowanie sterowników SATA z dysku lub pendrive’a. Próbowałem to na kilka sposobów i również się nie udało.

Ostatnia moja próba wynikająca już mojej własnej inwencji twórczej polegała na wymontowaniu napędu CD z laptopa. Jako, że nigdy tego nie robiłem to rozmontowałem wszystko co się dało, żeby odkryć, że wystarczyło wykręcić jedną śrubkę i po prostu napęd wyjąć. To było pouczające.

Tak czy inaczej – po wyjęciu napędu CD/DVD problem dotyczący sterowników nadal występował.

Spróbowałem zainstalować Windows Vista, który dostałem razem z laptopem i uruchomić z płyty instalator i po prostu zupgradować system z Visty do 7. To również nie dało efektu ponieważ 2 pliki DLL ( spwizeng.dll i wdscore.dll ) sprawiają problemy i nie daje się uruchomić instalacji pod Win Vista.

Wydaje mi się, że to nie jest dobry start dla Windowsa, aby przekonać mnie o swojej wyższości…

Jeśli ktoś ma jeszcze jakiś pomysł w jaki sposób można zmusić ten…. system do działania to proszę się nie ograniczać i napisać w komentarzach swoje przemyslenia.

Reklamy

9 myśli nt. „Windows 7

  1. Też miałem taki problem, a rozwiązanie na jakie wpadłem jest banalne.
    Wystarczy bowiem sformatować partycje z aktualnym systemem przez np. SystemRescueCD (tak aby zainstalować nowego windowsa potrzebujemy linuksa ;p).
    Problem u mnie pojawił się w momencie gdy na dysku miałem już Windowsa, nie pamiętam czy była to jakaś wersja siódemki czy XP, ale właśnie wtedy ów feralne okienko wyskakiwało i nic się nie dawało zrobić.
    Raz tylko miałem farta i po restarcie poszło jak należy, ale czemu, tego niewiadomo.
    Operację taką wymuszony byłem przeprowadzić bodaj dwukrotnie za każdym razem gdy chciałem sobie zainstalować świeżutka Windę.
    jak dla mnie sposób działa.

  2. Hmm… a może by tak wyczyścić MBR? Tutaj z kolei pomocna mogłaby być płytka WinXP. Kiedy formatowałeśpartycję usunąłeś ją, prawda?
    Bo nie wiem, co jeszcze. Odłącz wszelkie inne dyski, jeśli zawierają OSy i/lub informacje bootowania.

    No jeśli na jedynym czystym dysku nie pójdzie to to już przesada.
    Oczywiście sprawdzałeś sumy kontrolne płytki Win7?

  3. To jest laptop. Mam tylko jeden dysk. Próbowałem odłączania napędu CD/DVD co nic nie zmieniło.

    Na dysku mam jeszcze Linuxa a w MBR GRUBa. Win 7 nie jest na tyle interesujący aby bawić się z tym tygodniami więc po prostu poczekam aż wyjdzie jakaś wersja, która nie będzie taka problematyczna 🙂

    Tak czy inaczej dzięki za podsunięcie tego pomysłu.

  4. Dziwne „kolega” ma przemyślenia 🙂 to tak odnośnie syndromu wyższości. Z MAC OSX walczyłem przez czaso-okres 30 dni, udało mnie się połowicznie (D410 wystartował i OSX jakoś tam działał, MEDION jedynie kręcił jabuszkiem). Tym wprowadzeniem chcę wyrazić, że OSX, Linux czy nawet takie Win7 jako produkt uzurpuje sobie prawo do całego dysku i to według zaprogramowanego widzimisię i o niczym więcej to NIE ŚWIADCZY. GRUB w MBR może cokolwiek zgrzyt powodować. Z własnej praktyki jak już chcę mieć ładowacza to przypinam go do partycji primary i jest SPX gdyż mogę zawszę zmienić partycję rozruchową. Co się zaś tyczy opisanych przygód to jak jeszcze chęć zobaczenia W7 jest to tak właśnie bym postąpił. Przepiął GRUB-a z MBR na partycję primary, przygotował takąż dal W7 i zrobił z niej rozruchową i dokonał instalacji. Co do czasu jej trwania to w moim przypadku W7 na D410 instalowało się ~20-25minut a na MEDION-ie blisko 2h. Pozdrawiam i sukcesów życzę z tym UNIX-em 🙂 w M$ okienkach.

    • Teraz nie chcę już sobie psuć dobrego humoru próbami instalacji windowsa na komputerze ^^ Ani mi nie sprawia radości ani nie jest potrzebne.

      Może później zastanowie się czy ten GRUB rzeczywiście mógł namieszać.

  5. Witam!

    Pierwszy raz widzę takie problemy z instalacją Win7 – instaluje ich sporo i nie miałem takich anomalii. Widać Win7 nie lubi obecności Linux’a 🙂 – co może być logiczne. W każdym razie Win7 instalowany na czystą partycję i MBR nie sprawia najmneijszych problemów, a sam system sprawuje sie doskonale – i nie myślcie sobie, że jestem fanboy’em Windowsa.

    • Ja miałem dostęp do wersji RTM z uczelni i to był cały problem. Po premierze był już dostęp w MSDNAA do wersji zwykłej i ta zainstalowała się i chodziła bez problemu.

      Nawet przez tydzień jej używałem, zanim zaczęła mnie denerwować 🙂
      Wróciłem jednak do Gentoo, a Win7 odpalam jak chcę sobie w coś zagrać czyli nieczęsto 😛

Skomentuj

Wprowadź swoje dane lub kliknij jedną z tych ikon, aby się zalogować:

Logo WordPress.com

Komentujesz korzystając z konta WordPress.com. Wyloguj / Zmień )

Zdjęcie z Twittera

Komentujesz korzystając z konta Twitter. Wyloguj / Zmień )

Zdjęcie na Facebooku

Komentujesz korzystając z konta Facebook. Wyloguj / Zmień )

Zdjęcie na Google+

Komentujesz korzystając z konta Google+. Wyloguj / Zmień )

Connecting to %s